5411 C++ Programming Manual: D:/5411/Cpp Directory Reference

5411 C++ Programming Manual
Cpp Directory Reference

Files

file JY5411.h
@SectionBegin JY5411 FileHead
Generated by doxygen 1.9.1


5411 C++ Programming Manual: D:/5411/Cpp/JY5411.h File Reference

Macros | Typedefs | Enumerations | Functions
JY5411.h File Reference

@SectionBegin JY5411 FileHead More...

Macros

#define __DLL_JY5411_DEVICE_H__

Typedefs

typedef void * JY5411_DeviceHandle
@SectionEnd JY5411_Device FileHead More...

Enumerations

enum | JY5411_DI_SampleMode { JY5411_DI_Single = 0x0 , JY5411_DI_Finite = 0x1 , JY5411_DI_Continuous = 0x2 }
DI Sample Mode. More...
enum | JY5411_DO_UpdateMode { JY5411_DO_Single = 0x0 , JY5411_DO_Finite = 0x1 , JY5411_DO_ContinuousWrapping = 0x2 , JY5411_DO_ContinuousNoWrapping = 0x3 }
Digital signal output Mode. More...
enum | JY5411_DI_TriggerMode { JY5411_DI_StartTrigger = 0x0 , JY5411_DI_ReferenceTrigger = 0x1 }
enum | JY5411_DO_TriggerMode { JY5411_DO_StartTrigger = 0x0 }
enum | JY5411_DIO_TriggerType { JY5411_DIO_Immediately = 0x0 , JY5411_DIO_Digital = 0x1 , JY5411_DIO_Soft = 0x2 }
enum JY5411_DigitalTriggerSource {
JY5411_PFI0 = 0x0 , JY5411_PFI1 = 0x1 , JY5411_PFI2 = 0x2 , JY5411_PFI3 = 0x3 ,
JY5411_PFI4 = 0x4 , JY5411_PFI5 = 0x5 , JY5411_PFI6 = 0x6 , JY5411_PFI7 = 0x7 ,
JY5411_PXI_Trig0 = 0x8 , JY5411_PXI_Trig1 = 0x9 , JY5411_PXI_Trig2 = 0xA , JY5411_PXI_Trig3 = 0xB ,
JY5411_PXI_Trig4 = 0xC , JY5411_PXI_Trig5 = 0xD , JY5411_PXI_Trig6 = 0xE , JY5411_PXI_Trig7 = 0xF ,
JY5411_Inter_DI_StartTrig = 89 , JY5411_Inter_DI_ReferenceTrig = 91 , JY5411_Inter_DO_StartTrig = 95
}
enum | JY5411_DigitalTriggerEdge { JY5411_Rising = 0x0 , JY5411_Falling = 0x1 }
enum | JY5411_ClockEdge { JY5411_Clock_Rising = 0x1 , JY5411_Clock_Falling = 0x2 }
enum | JY5411_Power_Level { Level_1p8 = 0 , Level_2p5 = 1 , Level_3p3 = 2 , Level_5p0 = 3 }
enum | JY5411_DIO_SampleClockSource { JY5411_DIO_InternalClock = 0x0 , JY5411_DIO_ExternalClock = 0x1 }
enum JY5411_DIO_ExternalSampleClockTerminal {
JY5411_Clock_PXIeDStarA = 0x1 , JY5411_Clock_PXIeDStarB = 0x2 , JY5411_Clock_PXIStar = 0x3 , JY5411_Clock_SYNC100 = 0x5 ,
JY5411_Clock_PFI0 = 0xA , JY5411_Clock_PFI1 = 0xB , JY5411_Clock_PFI2 = 0xC , JY5411_Clock_PFI3 = 0xD ,
JY5411_Clock_PFI4 = 0xE , JY5411_Clock_PFI5 = 0xF , JY5411_Clock_PFI6 = 0x10 , JY5411_Clock_PFI7 = 0x11 ,
JY5411_Clock_PXITrig0 = 0x12 , JY5411_Clock_PXITrig1 = 0x13 , JY5411_Clock_PXITrig2 = 0x14 , JY5411_Clock_PXITrig3 = 0x15 ,
JY5411_Clock_PXITrig4 = 0x16 , JY5411_Clock_PXITrig5 = 0x17 , JY5411_Clock_PXITrig6 = 0x18 , JY5411_Clock_PXITrig7 = 0x19 ,
JY5411_Inter_DI_SampleClock = 84 , JY5411_Inter_DO_SampleClock = 83
}
enum | JY5411_ReferenceClock { JY5411_Internal = 0x1 , JY5411_PXIe_DStarA = 0x3 , JY5411_PXI_Clk100 = 0x2 }
enum JY5411_SignalSource {
JY5411_DI_SampleClock = 84 , JY5411_DI_StartTrig = 89 , JY5411_DI_ReferenceTrig = 91 , JY5411_DO_SampleClock = 83 ,
JY5411_DO_StartTrig = 95
}
enum JY5411_DestinationTerminal {
JY5411_Terminal_PFI0 = 32 , JY5411_Terminal_PFI1 = 33 , JY5411_Terminal_PFI2 = 34 , JY5411_Terminal_PFI3 = 35 ,
JY5411_Terminal_PFI4 = 36 , JY5411_Terminal_PFI5 = 37 , JY5411_Terminal_PFI6 = 38 , JY5411_Terminal_PFI7 = 39 ,
JY5411_Terminal_PXITrig0 = 40 , JY5411_Terminal_PXITrig1 = 41 , JY5411_Terminal_PXITrig2 = 42 , JY5411_Terminal_PXITrig3 = 43 ,
JY5411_Terminal_PXITrig4 = 44 , JY5411_Terminal_PXITrig5 = 45 , JY5411_Terminal_PXITrig6 = 46 , JY5411_Terminal_PXITrig7 = 47
}

Functions

JY5411API int | JY5411_Open (int slotNumber, JY5411_DeviceHandle *hDevice)
Open the 5411 board using the slot number or the board serial number. More...
JY5411API int | JY5411_OpenByName (const char *cardName, JY5411_DeviceHandle *hDevice)
Open this 5411 board using the board alias name which is set by JYTEK utility JYDM. More...
JY5411API int | JY5411_Close (JY5411_DeviceHandle hDevice)
Close this 5411 board. More...
JY5411API int | JY5411_GetDeviceID (JY5411_DeviceHandle hDevice, int *deviceID)
Obtain the board ID. More...
JY5411API int | JY5411_GetDeviceSerialNumber (JY5411_DeviceHandle hDevice, char *serialNumber, int length)
Obtain the device serialNumber More...
JY5411API int | JY5411_DisconnectSignalRouting (JY5411_DeviceHandle hDevice, int source)
Disconnect an established routing. More...
JY5411API int | JY5411_DI_AddLines (JY5411_DeviceHandle hDevice, int *lineID, unsigned int lineCount)
Enable DI channels. More...
JY5411API int | JY5411_DI_SetSampleClock (JY5411_DeviceHandle hDevice, JY5411_DIO_SampleClockSource clockSource, JY5411_ClockEdge clockEdge, JY5411_DIO_ExternalSampleClockTerminal terminal, double expectedRate)
Set DI sampling clock source. More...
JY5411API int | JY5411_SetDeviceReferenceClock (JY5411_DeviceHandle hDevice, JY5411_ReferenceClock refClockSource, double RefClockSourceFrequency)
Set Device reference clock for the device. More...
JY5411API int | JY5411_SetPFIPower (JY5411_DeviceHandle hDevice, JY5411_Power_Level powerLevel)
Set power level More...
JY5411API int | JY5411_SignalRouting (JY5411_DeviceHandle hDevice, JY5411_SignalSource SourceSignal, JY5411_DestinationTerminal SignalTerminal)
Route a singal from source to destination. More...
JY5411API int | JY5411_DI_ReadData (JY5411_DeviceHandle hDevice, unsigned int *dataBuffer, unsigned int dataLength, int timeOut, unsigned int *actualReadLength)
Read DI data. More...
JY5411API int | JY5411_DI_ReadSinglePoint (JY5411_DeviceHandle hDevice, bool *readValues, int lineID)
DI read single data from a single line by lineID defined.if the lineID == -1,read all line data. More...
JY5411API int | JY5411_DI_ReadSinglePoint_U32 (JY5411_DeviceHandle hDevice, unsigned long *readValue)
DI read single data from all line. More...
JY5411API int | JY5411_DI_Start (JY5411_DeviceHandle hDevice)
Start DI acquisition. More...
JY5411API int | JY5411_DI_Stop (JY5411_DeviceHandle hDevice)
Stop DI acquisition. More...
JY5411API int | JY5411_DI_SetMode (JY5411_DeviceHandle hDevice, JY5411_DI_SampleMode mode)
Set DI sampling mode More...
JY5411API int | JY5411_DI_SetSamplesToAcquire (JY5411_DeviceHandle hDevice, int samplesToAcquire)
Set DI samples to acquire for each channel in finite mode. More...
JY5411API int | JY5411_DI_CheckBufferStatus (JY5411_DeviceHandle hDevice, unsigned long long *avaliableSamples, bool *overrun)
Check DI device buffer status.This API is intended to be compatible with older version drivers. More...
JY5411API int | JY5411_DI_CheckBufferStatusEx (JY5411_DeviceHandle hDevice, unsigned long long *avaliableSamples, unsigned long long *transferedSamples, bool *overrun)
Check DI device buffer status. More...
JY5411API int | JY5411_DI_SetStartTriggerType (JY5411_DeviceHandle hDevice, JY5411_DIO_TriggerType triggerType)
Set DI start trigger type,the triggerType is defined by enum JY5411_DIO_TriggerType More...
JY5411API int | JY5411_DI_SetDigitalStartTrigger (JY5411_DeviceHandle hDevice, JY5411_DigitalTriggerSource triggerSource, JY5411_DigitalTriggerEdge triggerEdge)
Set DI digital start trigger,the triggerSource is defined by enum JY5411_DigitalTriggerSource, the triggerEdge is defined by enum JY5411_DigitalTriggerEdge. More...
JY5411API int | JY5411_DI_SetReferenceTriggerType (JY5411_DeviceHandle hDevice, JY5411_DIO_TriggerType triggerType)
Set DI reference trigger type,the triggerType is defined by enum JY5411_DIO_TriggerType. More...
JY5411API int | JY5411_DI_SetDigitalReferenceTrigger (JY5411_DeviceHandle hDevice, JY5411_DigitalTriggerSource triggerSource, JY5411_DigitalTriggerEdge triggerEdge)
Set DI digital reference trigger,the triggerSource is defined by enum JY5411_DigitalTriggerSource, the triggerEdge is defined by enum JY5411_DigitalTriggerEdge. More...
JY5411API int | JY5411_DI_SetPreTriggerSamples (JY5411_DeviceHandle hDevice, unsigned int preTriggerSamples)
Set DI pretrigger samples, the samples must greater than 0. More...
JY5411API int | JY5411_DI_SetReTriggerCount (JY5411_DeviceHandle hDevice, unsigned int reTriggerCount)
Set DI retrigger count. More...
JY5411API int | JY5411_DI_SetTriggerDelay (JY5411_DeviceHandle hDevice, unsigned int delay)
Set DI start trigger delay tap, only avaliable for the DI digital start trigger More...
JY5411API int | JY5411_DI_SendSoftTrigger (JY5411_DeviceHandle hDevice, JY5411_DI_TriggerMode triggermode)
Send the software trigger signal for DI. More...
JY5411API int | JY5411_DI_WaitUntilDone (JY5411_DeviceHandle hDevice, bool *done)
Check if DI acquisition is completed in finite mode. More...
JY5411API int | JY5411_DI_SetSampleRate (JY5411_DeviceHandle hDevice, double sampleRate, double *actualSampleRate)
Set sampling rate. More...
JY5411API int | JY5411_DO_AddLines (JY5411_DeviceHandle hDevice, int *lineID, unsigned int lineCount)
Enable DO channels. More...
JY5411API int | JY5411_DO_SetSampleClock (JY5411_DeviceHandle hDevice, JY5411_DIO_SampleClockSource clockSource, JY5411_ClockEdge clockEdge, JY5411_DIO_ExternalSampleClockTerminal terminal, double expectedRate)
Set DO sampling clock source. More...
JY5411API int | JY5411_DO_SetUpdateRate (JY5411_DeviceHandle hDevice, double updateRate, double *actualUpdateRate)
Set DO update rate.The update rate is the same for all channels. More...
JY5411API int | JY5411_DO_WriteData (JY5411_DeviceHandle hDevice, unsigned int *dataBuffer, unsigned int dataLength, int timeOut, unsigned int *actualWriteLength)
DO write data.The data type is uint. More...
JY5411API int | JY5411_DO_WriteSinglePoint (JY5411_DeviceHandle hDevice, bool *writeValues, int lineID)
DO write single data to a single line by lineID defined.if the lineID == -1,write all line data. More...
JY5411API int | JY5411_DO_WriteSinglePoint_U32 (JY5411_DeviceHandle hDevice, unsigned long writeValue)
DO write single data to all line. More...
JY5411API int | JY5411_DO_Start (JY5411_DeviceHandle hDevice)
Start Digital signal output. More...
JY5411API int | JY5411_DO_Stop (JY5411_DeviceHandle hDevice)
Stop Digital signal output. More...
JY5411API int | JY5411_DO_SetMode (JY5411_DeviceHandle hDevice, JY5411_DO_UpdateMode mode)
Set Digital signal output mode, the mode defined by enum JY5411_DO_UpdateMode. More...
JY5411API int | JY5411_DO_SetSamplesToUpdate (JY5411_DeviceHandle hDevice, int samplesToUpdate)
Set DO samples to update for each channel in finite mode. More...
JY5411API int | JY5411_DO_CheckBufferStatus (JY5411_DeviceHandle hDevice, unsigned long *avaliableSamples, bool *overrun)
Check DO device buffer status.This API is intended to be compatible with older version drivers. More...
JY5411API int | JY5411_DO_CheckBufferStatusEx (JY5411_DeviceHandle hDevice, unsigned long *avaliableSamples, unsigned long long *transferedSamples, bool *overrun)
Check DO device buffer status. More...
JY5411API int | JY5411_DO_WaitUntilDone (JY5411_DeviceHandle hDevice, bool *done, int timeOut)
Check if Digital signal output is completed in finite mode. More...
JY5411API int | JY5411_DO_SetStartTriggerType (JY5411_DeviceHandle hDevice, JY5411_DIO_TriggerType triggerType)
Set DO start trigger type,the triggerType is defined by enum JY5411_DIO_TriggerType More...
JY5411API int | JY5411_DO_SetTriggerDelay (JY5411_DeviceHandle hDevice, unsigned int delay)
Set DO start trigger delay tap, only avaliable for the DO digital start trigger More...
JY5411API int | JY5411_DO_SetDigitalStartTrigger (JY5411_DeviceHandle hDevice, JY5411_DigitalTriggerSource triggerSource, JY5411_DigitalTriggerEdge triggerEdge)
Set DO digital start trigger,the triggerSource is defined by enum JY5411_DigitalTriggerSource, the triggerEdge is defined by enum JY5411_DigitalTriggerEdge. More...
JY5411API int | JY5411_DO_SendSoftTrigger (JY5411_DeviceHandle hDevice)
Send the software trigger signal for DO. More...
JY5411API int | JY5411_SetDeviceStatusLed (JY5411_DeviceHandle hDevice, bool enable, unsigned int frequency)
Control Front Panel Status Led More...

Detailed Description

@SectionBegin JY5411 FileHead

COPYRIGHT NOTICE
Copyright (c) 2018-2021, JYTEK
All rights reserved.
Author
JYTEK
Version
4.0.3
Date
2022-6-28

This header file defines C/C++ API and enums used in the JY5500 driver.

Revision Notes:

Macro Definition Documentation

◆ __DLL_JY5411_DEVICE_H__

#define __DLL_JY5411_DEVICE_H__

Typedef Documentation

◆ JY5411_DeviceHandle

typedef void* JY5411_DeviceHandle

@SectionEnd JY5411_Device FileHead

Windows Linux

Enumeration Type Documentation

◆ JY5411_ClockEdge

enum JY5411_ClockEdge
Enumerator
JY5411_Clock_Rising | Rsing edge for clock edge.
JY5411_Clock_Falling | Falling edge for clock edge.

◆ JY5411_DestinationTerminal

enum JY5411_DestinationTerminal
Enumerator
JY5411_Terminal_PFI0 |
JY5411_Terminal_PFI1 | PFI0 as the signal desition to rout.
JY5411_Terminal_PFI2 | PFI1 as the signal desition to rout.
JY5411_Terminal_PFI3 | PFI2 as the signal desition to rout.
JY5411_Terminal_PFI4 | PFI3 as the signal desition to rout.
JY5411_Terminal_PFI5 | PFI4 as the signal desition to rout.
JY5411_Terminal_PFI6 | PFI5 as the signal desition to rout.
JY5411_Terminal_PFI7 | PFI6 as the signal desition to rout.
JY5411_Terminal_PXITrig0 | PFI7 as the signal desition to rout.
JY5411_Terminal_PXITrig1 | PXITriggerBus0 as the signal desition to rout.
JY5411_Terminal_PXITrig2 | PXITriggerBus1 as the signal desition to rout.
JY5411_Terminal_PXITrig3 | PXITriggerBus2 as the signal desition to rout.
JY5411_Terminal_PXITrig4 | PXITriggerBus3 as the signal desition to rout.
JY5411_Terminal_PXITrig5 | PXITriggerBus4 as the signal desition to rout.
JY5411_Terminal_PXITrig6 | PXITriggerBus5 as the signal desition to rout.
JY5411_Terminal_PXITrig7 | PXITriggerBus6 as the signal desition to rout.

◆ JY5411_DI_SampleMode

enum JY5411_DI_SampleMode

DI Sample Mode.

Enumerator
JY5411_DI_Single | DI Single mode.
JY5411_DI_Finite | DI Finite mode.
JY5411_DI_Continuous | DI Continuous mode.

◆ JY5411_DI_TriggerMode

enum JY5411_DI_TriggerMode
Enumerator
JY5411_DI_StartTrigger | Start trigger mode.
JY5411_DI_ReferenceTrigger | Reference trigger mode.

◆ JY5411_DigitalTriggerEdge

enum JY5411_DigitalTriggerEdge
Enumerator
JY5411_Rising | Rsing edge for digital trigger edge.
JY5411_Falling | Falling edge for digital trigger edge.

◆ JY5411_DigitalTriggerSource

enum JY5411_DigitalTriggerSource
Enumerator
JY5411_PFI0 | PFI_0 as the digital trigger source.
JY5411_PFI1 | PFI_1 as the digital trigger source.
JY5411_PFI2 | PFI_2 as the digital trigger source.
JY5411_PFI3 | PFI_3 as the digital trigger source.
JY5411_PFI4 | PFI_4 as the digital trigger source.
JY5411_PFI5 | PFI_5 as the digital trigger source.
JY5411_PFI6 | PFI_6 as the digital trigger source.
JY5411_PFI7 | PFI_7 as the digital trigger source.
JY5411_PXI_Trig0 | PXI_Trig0 as the digital trigger source.
JY5411_PXI_Trig1 | PXI_Trig1 as the digital trigger source.
JY5411_PXI_Trig2 | PXI_Trig2 as the digital trigger source.
JY5411_PXI_Trig3 | PXI_Trig3 as the digital trigger source.
JY5411_PXI_Trig4 | PXI_Trig4 as the digital trigger source.
JY5411_PXI_Trig5 | PXI_Trig5 as the digital trigger source.
JY5411_PXI_Trig6 | PXI_Trig6 as the digital trigger source.
JY5411_PXI_Trig7 | PXI_Trig7 as the digital trigger source.
JY5411_Inter_DI_StartTrig | DI_StartTrig as the digital trigger source.
JY5411_Inter_DI_ReferenceTrig | DI_ReferenceTrig as the digital trigger source.
JY5411_Inter_DO_StartTrig | DO_StartTrig as the digital trigger source.

◆ JY5411_DIO_ExternalSampleClockTerminal

enum JY5411_DIO_ExternalSampleClockTerminal
Enumerator
JY5411_Clock_PXIeDStarA |
JY5411_Clock_PXIeDStarB | PXIeDStarA for external sampleclock terminal.
JY5411_Clock_PXIStar | PXIeDStarB for external sampleclock terminal.
JY5411_Clock_SYNC100 | PXIStar for external sampleclock terminal.
JY5411_Clock_PFI0 | SYNC100 for external sampleclock terminal.
JY5411_Clock_PFI1 | PFI0 for external sampleclock terminal.
JY5411_Clock_PFI2 | PFI1 for external sampleclock terminal.
JY5411_Clock_PFI3 | PFI2 for external sampleclock terminal.
JY5411_Clock_PFI4 | PFI3 for external sampleclock terminal.
JY5411_Clock_PFI5 | PFI4 for external sampleclock terminal.
JY5411_Clock_PFI6 | PFI5 for external sampleclock terminal.
JY5411_Clock_PFI7 | PFI6 for external sampleclock terminal.
JY5411_Clock_PXITrig0 | PFI7 for external sampleclock terminal.
JY5411_Clock_PXITrig1 | PXITriggerBus0 for external sampleclock terminal.
JY5411_Clock_PXITrig2 | PXITriggerBus1 for external sampleclock terminal.
JY5411_Clock_PXITrig3 | PXITriggerBus2 for external sampleclock terminal.
JY5411_Clock_PXITrig4 | PXITriggerBus3 for external sampleclock terminal.
JY5411_Clock_PXITrig5 | PXITriggerBus4 for external sampleclock terminal.
JY5411_Clock_PXITrig6 | PXITriggerBus5 for external sampleclock terminal.
JY5411_Clock_PXITrig7 | PXITriggerBus6 for external sampleclock terminal.
JY5411_Inter_DI_SampleClock | PXITriggerBus7 for external sampleclock terminal.
JY5411_Inter_DO_SampleClock | DI_SampleClock_Out for external sampleclock terminal.

◆ JY5411_DIO_SampleClockSource

enum JY5411_DIO_SampleClockSource
Enumerator
JY5411_DIO_InternalClock | Internal Clock Source.
JY5411_DIO_ExternalClock | External Clock Source.

◆ JY5411_DIO_TriggerType

enum JY5411_DIO_TriggerType
Enumerator
JY5411_DIO_Immediately | Immediately trigger type.
JY5411_DIO_Digital | Digital trigger type.
JY5411_DIO_Soft | Soft trigger type.

◆ JY5411_DO_TriggerMode

enum JY5411_DO_TriggerMode
Enumerator
JY5411_DO_StartTrigger

Start trigger mode.

◆ JY5411_DO_UpdateMode

enum JY5411_DO_UpdateMode

Digital signal output Mode.

Enumerator
JY5411_DO_Single | DO Single mode.
JY5411_DO_Finite | DO Finite mode.
JY5411_DO_ContinuousWrapping | DO ContinuousWrapping mode.
JY5411_DO_ContinuousNoWrapping | DO ContinuousNoWrapping mode.

◆ JY5411_Power_Level

enum JY5411_Power_Level
Enumerator
Level_1p8 | power level 1.8V
Level_2p5 | power level 2.5V
Level_3p3 | power level 3.3V
Level_5p0 | power level 5.0V

◆ JY5411_ReferenceClock

enum JY5411_ReferenceClock
Enumerator
JY5411_Internal |
JY5411_PXIe_DStarA | OnBoard10M for reference clock source.
JY5411_PXI_Clk100 | PXIe_DSTARA for reference clock source.

◆ JY5411_SignalSource

enum JY5411_SignalSource
Enumerator
JY5411_DI_SampleClock |
JY5411_DI_StartTrig | DI_SampleCLK_Out as the source signal to rout.
JY5411_DI_ReferenceTrig | DI_Start_trigger_out as the source signal to rout.
JY5411_DO_SampleClock | DI_Reference_trigger_out as the source signal to rout.
JY5411_DO_StartTrig | DO_SampleCLK_Out as the source signal to rout.

Function Documentation

◆ JY5411_Close()

JY5411API int JY5411_Close ( JY5411_DeviceHandle hDevice )

Close this 5411 board.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5411_DI_AddLines()

JY5411API int JY5411_DI_AddLines | ( | JY5411_DeviceHandle | hDevice,
 |  | int * | lineID,
 |  | unsigned int | lineCount
 | ) |  |

Enable DI channels.

Each channel can be independently configured

Parameters
hDevice | device handle
lineCount | number of channels to be enabled
lineID | array[channelCount] containing channel IDs
Returns
0 if success or other error code

◆ JY5411_DI_CheckBufferStatus()

JY5411API int JY5411_DI_CheckBufferStatus | ( | JY5411_DeviceHandle | hDevice,
 |  | unsigned long long * | avaliableSamples,
 |  | bool * | overrun
 | ) |  |

Check DI device buffer status.This API is intended to be compatible with older version drivers.

It is recommended to use API JY5411_DI_CheckBufferStatusEx.

Parameters
hDevice | device handle
avaliableSamples | number of samples per channel in the device buffer
overrun | true if overflow, false if not overflow.
Returns
0 if success or other error code

◆ JY5411_DI_CheckBufferStatusEx()

JY5411API int JY5411_DI_CheckBufferStatusEx | ( | JY5411_DeviceHandle | hDevice,
 |  | unsigned long long * | avaliableSamples,
 |  | unsigned long long * | transferedSamples,
 |  | bool * | overrun
 | ) |  |

Check DI device buffer status.

Parameters
hDevice | device handle
avaliableSamples | number of samples per channel in the device buffer
transferedSamples | The number of samples that have been transfered from the device buffer (per channel)
overrun | true if overflow, false if not overflow.
Returns
0 if success or other error code

◆ JY5411_DI_ReadData()

JY5411API int JY5411_DI_ReadData | ( | JY5411_DeviceHandle | hDevice,
 |  | unsigned int * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualReadLength
 | ) |  |

Read DI data.

The data type is uint. There are 32 lines, from 0 to 31. Each bit represents one line.

Parameters
hDevice | device handle
dataBuffer | user buffer, the size of dataBuffer must be greater than or equal to dataLength.
dataLength | number of samples per channel
timeOut | timeout time in microsecond
actualReadLength | the actual length of the data read
Returns
0 if success or other error code

◆ JY5411_DI_ReadSinglePoint()

JY5411API int JY5411_DI_ReadSinglePoint | ( | JY5411_DeviceHandle | hDevice,
 |  | bool * | readValues,
 |  | int | lineID
 | ) |  |

DI read single data from a single line by lineID defined.if the lineID == -1,read all line data.

Parameters
hDevice | device handle
readValues | read the specified line value. when the lineID is -1, read all enabled lines values,the readValues Length must equal to lineCount(In function JY5411_DI_AddLines defined), and the values store in the add order of lines.
lineID | line number
Returns
0 if success or other error code

◆ JY5411_DI_ReadSinglePoint_U32()

JY5411API int JY5411_DI_ReadSinglePoint_U32 | ( | JY5411_DeviceHandle | hDevice,
 |  | unsigned long * | readValue
 | ) |  |

DI read single data from all line.

the data type is unsigned long,the data each bit from low to high defined one line status.

Parameters
hDevice device handle
readValue read all line value.
Returns
0 if success or other error code

◆ JY5411_DI_SendSoftTrigger()

JY5411API int JY5411_DI_SendSoftTrigger | ( | JY5411_DeviceHandle | hDevice,
 |  | JY5411_DI_TriggerMode | triggermode
 | ) |  |

Send the software trigger signal for DI.

Parameters
hDevice | device handle
triggerMode | software trigger mode. Options: start trigger or reference trigger.
Returns
0 if success or other error code

◆ JY5411_DI_SetDigitalReferenceTrigger()

JY5411API int JY5411_DI_SetDigitalReferenceTrigger | ( | JY5411_DeviceHandle | hDevice,
 |  | JY5411_DigitalTriggerSource | triggerSource,
 |  | JY5411_DigitalTriggerEdge | triggerEdge
 | ) |  |

Set DI digital reference trigger,the triggerSource is defined by enum JY5411_DigitalTriggerSource, the triggerEdge is defined by enum JY5411_DigitalTriggerEdge.

Parameters
hDevice | device handle
triggerSource | DI reference trigger source
triggerEdge | DI reference to the trigger edge. Options: rising or falling edge
Returns
0 if success or other error code

◆ JY5411_DI_SetDigitalStartTrigger()

JY5411API int JY5411_DI_SetDigitalStartTrigger | ( | JY5411_DeviceHandle | hDevice,
 |  | JY5411_DigitalTriggerSource | triggerSource,
 |  | JY5411_DigitalTriggerEdge | triggerEdge
 | ) |  |

Set DI digital start trigger,the triggerSource is defined by enum JY5411_DigitalTriggerSource, the triggerEdge is defined by enum JY5411_DigitalTriggerEdge.

Parameters
hDevice | device handle
triggerSource | DI digital start trigger source
triggerEdge | DI digital start trigger edge. Options: rising or falling edge
Returns
0 if success or other error code

◆ JY5411_DI_SetMode()

JY5411API int JY5411_DI_SetMode | ( | JY5411_DeviceHandle | hDevice,
 |  | JY5411_DI_SampleMode | mode
 | ) |  |

Set DI sampling mode

Parameters
hDevice | device handle
mode | DI sampling mode defined by enum JY5411_DI_SampleMode which can be of single point,continuous finite,continuous mode.
Returns
0 if success or other error code

◆ JY5411_DI_SetPreTriggerSamples()

JY5411API int JY5411_DI_SetPreTriggerSamples | ( | JY5411_DeviceHandle | hDevice,
 |  | unsigned int | preTriggerSamples
 | ) |  |

Set DI pretrigger samples, the samples must greater than 0.

Parameters
hDevice | device handle
preTriggerSamples | DI pretrigger samples, valid only in reference trigger mode.
Returns
0 if success or other error code

◆ JY5411_DI_SetReferenceTriggerType()

JY5411API int JY5411_DI_SetReferenceTriggerType | ( | JY5411_DeviceHandle | hDevice,
 |  | JY5411_DIO_TriggerType | triggerType
 | ) |  |

Set DI reference trigger type,the triggerType is defined by enum JY5411_DIO_TriggerType.

Parameters
hDevice | device handle
triggerType | DI reference trigger type. Options: immediate trigger, software trigger, digital trigger.
Returns
0 if success or other error code

◆ JY5411_DI_SetReTriggerCount()

JY5411API int JY5411_DI_SetReTriggerCount | ( | JY5411_DeviceHandle | hDevice,
 |  | unsigned int | reTriggerCount
 | ) |  |

Set DI retrigger count.

The device will be triggered reTriggerCount times.

Parameters
hDevice | device handle
reTriggerCount | DI retrigger count
Returns
0 if success or other error code

◆ JY5411_DI_SetSampleClock()

JY5411API int JY5411_DI_SetSampleClock | ( | JY5411_DeviceHandle | hDevice,
 |  | JY5411_DIO_SampleClockSource | clockSource,
 |  | JY5411_ClockEdge | clockEdge,
 |  | JY5411_DIO_ExternalSampleClockTerminal | terminal,
 |  | double | expectedRate
 | ) |  |

Set DI sampling clock source.

the source of the sampling clock defined by enum JY5411_ClockSource. If the clock source is external, external clock terminal and external clock frequency must be configured.

Parameters
hDevice | device handle
clockSource | DI sampling clock source
clockEdge | DI sampling clock edge
terminal | external terminal
expectedRate | DI external clock frequency
Returns
0 if success or other error code

◆ JY5411_DI_SetSampleRate()

JY5411API int JY5411_DI_SetSampleRate | ( | JY5411_DeviceHandle | hDevice,
 |  | double | sampleRate,
 |  | double * | actualSampleRate
 | ) |  |

Set sampling rate.

The sampling rate is the same for all channels.

Parameters
hDevice | device handle
sampleRate | DI sampling rate to be set per channel
actualSampleRate | actual sampling rate set by this device,which may be different from the desired sampleRate.
Returns
0 if success or other error code

◆ JY5411_DI_SetSamplesToAcquire()

JY5411API int JY5411_DI_SetSamplesToAcquire | ( | JY5411_DeviceHandle | hDevice,
 |  | int | samplesToAcquire
 | ) |  |

Set DI samples to acquire for each channel in finite mode.

Parameters
hDevice | device handle
sampleToAcquire | DI finite samples to acquire for each channel
Returns
0 if success or other error code

◆ JY5411_DI_SetStartTriggerType()

JY5411API int JY5411_DI_SetStartTriggerType | ( | JY5411_DeviceHandle | hDevice,
 |  | JY5411_DIO_TriggerType | triggerType
 | ) |  |

Set DI start trigger type,the triggerType is defined by enum JY5411_DIO_TriggerType

Parameters
hDevice | device handle
triggerType | DI start trigger type. Options: immediate trigger, software trigger, digital trigger.
Returns
0 if success or other error code

◆ JY5411_DI_SetTriggerDelay()

JY5411API int JY5411_DI_SetTriggerDelay | ( | JY5411_DeviceHandle | hDevice,
 |  | unsigned int | delay
 | ) |  |

Set DI start trigger delay tap, only avaliable for the DI digital start trigger

Parameters
hDevice | device handle
triggerDelayTap | DI start trigger delay,unit:sample.
Returns
0 if success or other error code

◆ JY5411_DI_Start()

JY5411API int JY5411_DI_Start ( JY5411_DeviceHandle hDevice )

Start DI acquisition.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5411_DI_Stop()

JY5411API int JY5411_DI_Stop ( JY5411_DeviceHandle hDevice )

Stop DI acquisition.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5411_DI_WaitUntilDone()

JY5411API int JY5411_DI_WaitUntilDone | ( | JY5411_DeviceHandle | hDevice,
 |  | bool * | done
 | ) |  |

Check if DI acquisition is completed in finite mode.

Parameters
hDevice | device handle
done | true:completed, false:not yet completed.
Returns
0 if success or other error code

◆ JY5411_DisconnectSignalRouting()

JY5411API int JY5411_DisconnectSignalRouting | ( | JY5411_DeviceHandle | hDevice,
 |  | int | source
 | ) |  |

Disconnect an established routing.

Parameters
hDevice | device handle
source | source of the signal defined by enum JY5411_SourceSignal
destination | destination of the signal defined by enum JY5411_DestinationSignal
Returns
0 if success or other error code

◆ JY5411_DO_AddLines()

JY5411API int JY5411_DO_AddLines | ( | JY5411_DeviceHandle | hDevice,
 |  | int * | lineID,
 |  | unsigned int | lineCount
 | ) |  |

Enable DO channels.

Each channel can be independently configured

Parameters
hDevice | device handle
lineCount | number of channels to be enabled
lineID | array[channelCount] containing channel IDs
Returns
0 if success or other error code

◆ JY5411_DO_CheckBufferStatus()

JY5411API int JY5411_DO_CheckBufferStatus | ( | JY5411_DeviceHandle | hDevice,
 |  | unsigned long * | avaliableSamples,
 |  | bool * | overrun
 | ) |  |

Check DO device buffer status.This API is intended to be compatible with older version drivers.

It is recommended to use API JY5411_DO_CheckBufferStatusEx.

Parameters
hDevice | device handle
avaliableSamples | number of samples per channel in the device buffer
overrun | true if overflow, false if not overflow.
Returns
0 if success or other error code

◆ JY5411_DO_CheckBufferStatusEx()

JY5411API int JY5411_DO_CheckBufferStatusEx | ( | JY5411_DeviceHandle | hDevice,
 |  | unsigned long * | avaliableSamples,
 |  | unsigned long long * | transferedSamples,
 |  | bool * | overrun
 | ) |  |

Check DO device buffer status.

Parameters
hDevice | device handle
avaliableSamples | number of samples per channel in the device buffer
transferedSamples | The number of samples that have been transfered from the device buffer (per channel)
overrun | true if overflow, false if not overflow.
Returns
0 if success or other error code

◆ JY5411_DO_SendSoftTrigger()

JY5411API int JY5411_DO_SendSoftTrigger ( JY5411_DeviceHandle hDevice )

Send the software trigger signal for DO.

Parameters
hDevice | device handle
triggerMode | software trigger mode. Options: start trigger.
Returns
0 if success or other error code

◆ JY5411_DO_SetDigitalStartTrigger()

JY5411API int JY5411_DO_SetDigitalStartTrigger | ( | JY5411_DeviceHandle | hDevice,
 |  | JY5411_DigitalTriggerSource | triggerSource,
 |  | JY5411_DigitalTriggerEdge | triggerEdge
 | ) |  |

Set DO digital start trigger,the triggerSource is defined by enum JY5411_DigitalTriggerSource, the triggerEdge is defined by enum JY5411_DigitalTriggerEdge.

Parameters
hDevice | device handle
triggerSource | DO digital start trigger source
triggerEdge | DI digital start trigger edge. Options: rising or falling edge
Returns
0 if success or other error code

◆ JY5411_DO_SetMode()

JY5411API int JY5411_DO_SetMode | ( | JY5411_DeviceHandle | hDevice,
 |  | JY5411_DO_UpdateMode | mode
 | ) |  |

Set Digital signal output mode, the mode defined by enum JY5411_DO_UpdateMode.

Parameters
hDevice | device handle
mode | Digital signal output mode.Options: Single,Finite,ContinuousWrapping,ContinuousNoWrapping mode.
Returns
0 if success or other error code

◆ JY5411_DO_SetSampleClock()

JY5411API int JY5411_DO_SetSampleClock | ( | JY5411_DeviceHandle | hDevice,
 |  | JY5411_DIO_SampleClockSource | clockSource,
 |  | JY5411_ClockEdge | clockEdge,
 |  | JY5411_DIO_ExternalSampleClockTerminal | terminal,
 |  | double | expectedRate
 | ) |  |

Set DO sampling clock source.

the source of the sampling clock defined by enum JY5411_DIO_SampleClockSource. If the clock source is external, external clock terminal and external clock frequency must be configured.

Parameters
hDevice | device handle
clockSource | DO sampling clock source
clockEdge | DO sampling clock edge
terminal | external terminal
expectedRate | DO external clock frequency
Returns
0 if success or other error code

◆ JY5411_DO_SetSamplesToUpdate()

JY5411API int JY5411_DO_SetSamplesToUpdate | ( | JY5411_DeviceHandle | hDevice,
 |  | int | samplesToUpdate
 | ) |  |

Set DO samples to update for each channel in finite mode.

Parameters
hDevice | device handle
samplesToUpdate | DO finite samples to update for each channel
Returns
0 if success or other error code

◆ JY5411_DO_SetStartTriggerType()

JY5411API int JY5411_DO_SetStartTriggerType | ( | JY5411_DeviceHandle | hDevice,
 |  | JY5411_DIO_TriggerType | triggerType
 | ) |  |

Set DO start trigger type,the triggerType is defined by enum JY5411_DIO_TriggerType

Parameters
hDevice | device handle
triggerType | DO start trigger type. Options: immediate trigger, software trigger, digital trigger.
Returns
0 if success or other error code

◆ JY5411_DO_SetTriggerDelay()

JY5411API int JY5411_DO_SetTriggerDelay | ( | JY5411_DeviceHandle | hDevice,
 |  | unsigned int | delay
 | ) |  |

Set DO start trigger delay tap, only avaliable for the DO digital start trigger

Parameters
hDevice | device handle
triggerDelayTap | DO start trigger delay , unit:sample.
Returns
0 if success or other error code

◆ JY5411_DO_SetUpdateRate()

JY5411API int JY5411_DO_SetUpdateRate | ( | JY5411_DeviceHandle | hDevice,
 |  | double | updateRate,
 |  | double * | actualUpdateRate
 | ) |  |

Set DO update rate.The update rate is the same for all channels.

Parameters
hDevice | device handle
sampleRate | DO update rate to be set per channel
actualSampleRate | actually set DO update rate,actual update rate set by this device,which may be different from the desired updata rate.
Returns
0 if success or other error code

◆ JY5411_DO_Start()

JY5411API int JY5411_DO_Start ( JY5411_DeviceHandle hDevice )

Start Digital signal output.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5411_DO_Stop()

JY5411API int JY5411_DO_Stop ( JY5411_DeviceHandle hDevice )

Stop Digital signal output.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5411_DO_WaitUntilDone()

JY5411API int JY5411_DO_WaitUntilDone | ( | JY5411_DeviceHandle | hDevice,
 |  | bool * | done,
 |  | int | timeOut
 | ) |  |

Check if Digital signal output is completed in finite mode.

Parameters
hDevice | device handle
done | true if completed, false if not yet completed.
Returns
0 if success or other error code

◆ JY5411_DO_WriteData()

JY5411API int JY5411_DO_WriteData | ( | JY5411_DeviceHandle | hDevice,
 |  | unsigned int * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualWriteLength
 | ) |  |

DO write data.The data type is uint.

There are 32 lines, from 0 to 31. Each bit represents one line.

Parameters
hDevice | device handle
dataBuffer | user buffer,the buffer size must be greater than or equal to dataLength.
dataLength | number of samples per channel
timeOut | timeout time in microsecond
actualWriteLength | Return value, the actual length of the data write
Returns
0 if success or other error code

◆ JY5411_DO_WriteSinglePoint()

JY5411API int JY5411_DO_WriteSinglePoint | ( | JY5411_DeviceHandle | hDevice,
 |  | bool * | writeValues,
 |  | int | lineID
 | ) |  |

DO write single data to a single line by lineID defined.if the lineID == -1,write all line data.

Parameters
hDevice | device handle
writeValues | write the specified line value. when the lineID is -1, write all enabled lines values,the writeValues Length must equal to lineCount(In function JY5411_DO_AddLines defined), and the values store in the add order of lines.
lineID | line number
Returns
0 if success or other error code

◆ JY5411_DO_WriteSinglePoint_U32()

JY5411API int JY5411_DO_WriteSinglePoint_U32 | ( | JY5411_DeviceHandle | hDevice,
 |  | unsigned long | writeValue
 | ) |  |

DO write single data to all line.

the data type is unsigned long,the data each bit from low to high defined one line status.

Parameters
hDevice device handle
writeValue write all line value.
Returns
0 if success or other error code

◆ JY5411_GetDeviceID()

JY5411API int JY5411_GetDeviceID | ( | JY5411_DeviceHandle | hDevice,
 |  | int * | deviceID
 | ) |  |

Obtain the board ID.

The 5411 is a series of boards. The PXIe-5411 board ID is 0x5411. The PCIe-5411 board ID is 0xA411. The USB-5411 board ID is 0xB411.

Parameters
hDevice | device handle
deviceID | board ID
Returns
0 if success or other error code

◆ JY5411_GetDeviceSerialNumber()

JY5411API int JY5411_GetDeviceSerialNumber | ( | JY5411_DeviceHandle | hDevice,
 |  | char * | serialNumber,
 |  | int | length
 | ) |  |

Obtain the device serialNumber

Parameters
hDevice | device handle
serialNumber | Pointer to a buffer receiving the serial number. The length of the serial number is 10.
length | serial Number length ,lenth is 10
Returns
0 if success or other error code

◆ JY5411_Open()

JY5411API int JY5411_Open | ( | int | slotNumber,
 |  | JY5411_DeviceHandle * | hDevice
 | ) |  |

Open the 5411 board using the slot number or the board serial number.

PXIe slot number is predefined by the PXIe chassis. PCIe slot number is defined by the DIP switch. The board serial number is defined by the system starting from 0. It's your responsibility to know the number. For a single board, the serial number is 0.

Parameters
slotNumber | slot number or board serial number
hDevice | device handle. All other functions uses hDevice to represent this device.
Returns
0 if success or other error code

◆ JY5411_OpenByName()

JY5411API int JY5411_OpenByName | ( | const char * | cardName,
 |  | JY5411_DeviceHandle * | hDevice
 | ) |  |

Open this 5411 board using the board alias name which is set by JYTEK utility JYDM.

You can change the name using JYDM.

Parameters
cardName | board alias name
hDevice | device handle
Returns
0 if success or other error code

◆ JY5411_SetDeviceReferenceClock()

JY5411API int JY5411_SetDeviceReferenceClock | ( | JY5411_DeviceHandle | hDevice,
 |  | JY5411_ReferenceClock | refClockSource,
 |  | double | RefClockSourceFrequency
 | ) |  |

Set Device reference clock for the device.

PCIe device only supports internal reference clock.

Parameters
hDevice | device handle
clkSource | reference clock source defined by enum JY5411_ReferenceClock
Returns
0 if success or other error code

◆ JY5411_SetDeviceStatusLed()

JY5411API int JY5411_SetDeviceStatusLed | ( | JY5411_DeviceHandle | hDevice,
 |  | bool | enable,
 |  | unsigned int | frequency
 | ) |  |

Control Front Panel Status Led

Parameters
hDevice | device handle
enable | enable front panel status led blink, true: blink, false: not blink
frequency | when enable is ture, the led blink speed by frequency define
Returns
0 if success or other error code

◆ JY5411_SetPFIPower()

JY5411API int JY5411_SetPFIPower | ( | JY5411_DeviceHandle | hDevice,
 |  | JY5411_Power_Level | powerLevel
 | ) |  |

Set power level

Parameters
hDevice | device handle
powerLevel | power level
Returns
0 if success or other error code

◆ JY5411_SignalRouting()

JY5411API int JY5411_SignalRouting | ( | JY5411_DeviceHandle | hDevice,
 |  | JY5411_SignalSource | SourceSignal,
 |  | JY5411_DestinationTerminal | SignalTerminal
 | ) |  |

Route a singal from source to destination.

Both source and destination are defined by the corresponding enum JY5411_SignalSource and JY5411_DestinationTerminal. One source signal may be routed to multiple destinations.

Parameters
hDevice | device handle
source | source of the signal defined by enum JY5411_SourceSignal
destination | destination of the signal defined by enum JY5411_DestinationTerminal
Returns
0 if success or other error code


5411 C++ Programming Manual: D:/5411 Directory Reference

  • D:
  • 5411
5411 Directory Reference

Directories

directory Cpp


5411 C++ Programming Manual: D: Directory Reference

  • D:
D: Directory Reference

Directories

directory 5411


5411 C++ Programming Manual: File List

File List
Here is a list of all files with brief descriptions:
[detail level 1234]
▼ D: |
▼ 5411 |
▼ Cpp |
JY5411.h | @SectionBegin JY5411 FileHead


5411 C++ Programming Manual: File Members

Here is a list of all file members with links to the files they belong to:

- _ -

  • __DLL_JY5411_DEVICE_H__ : JY5411.h

- j -

  • JY5411_Clock_Falling : JY5411.h
  • JY5411_Clock_PFI0 : JY5411.h
  • JY5411_Clock_PFI1 : JY5411.h
  • JY5411_Clock_PFI2 : JY5411.h
  • JY5411_Clock_PFI3 : JY5411.h
  • JY5411_Clock_PFI4 : JY5411.h
  • JY5411_Clock_PFI5 : JY5411.h
  • JY5411_Clock_PFI6 : JY5411.h
  • JY5411_Clock_PFI7 : JY5411.h
  • JY5411_Clock_PXIeDStarA : JY5411.h
  • JY5411_Clock_PXIeDStarB : JY5411.h
  • JY5411_Clock_PXIStar : JY5411.h
  • JY5411_Clock_PXITrig0 : JY5411.h
  • JY5411_Clock_PXITrig1 : JY5411.h
  • JY5411_Clock_PXITrig2 : JY5411.h
  • JY5411_Clock_PXITrig3 : JY5411.h
  • JY5411_Clock_PXITrig4 : JY5411.h
  • JY5411_Clock_PXITrig5 : JY5411.h
  • JY5411_Clock_PXITrig6 : JY5411.h
  • JY5411_Clock_PXITrig7 : JY5411.h
  • JY5411_Clock_Rising : JY5411.h
  • JY5411_Clock_SYNC100 : JY5411.h
  • JY5411_ClockEdge : JY5411.h
  • JY5411_Close() : JY5411.h
  • JY5411_DestinationTerminal : JY5411.h
  • JY5411_DeviceHandle : JY5411.h
  • JY5411_DI_AddLines() : JY5411.h
  • JY5411_DI_CheckBufferStatus() : JY5411.h
  • JY5411_DI_CheckBufferStatusEx() : JY5411.h
  • JY5411_DI_Continuous : JY5411.h
  • JY5411_DI_Finite : JY5411.h
  • JY5411_DI_ReadData() : JY5411.h
  • JY5411_DI_ReadSinglePoint() : JY5411.h
  • JY5411_DI_ReadSinglePoint_U32() : JY5411.h
  • JY5411_DI_ReferenceTrig : JY5411.h
  • JY5411_DI_ReferenceTrigger : JY5411.h
  • JY5411_DI_SampleClock : JY5411.h
  • JY5411_DI_SampleMode : JY5411.h
  • JY5411_DI_SendSoftTrigger() : JY5411.h
  • JY5411_DI_SetDigitalReferenceTrigger() : JY5411.h
  • JY5411_DI_SetDigitalStartTrigger() : JY5411.h
  • JY5411_DI_SetMode() : JY5411.h
  • JY5411_DI_SetPreTriggerSamples() : JY5411.h
  • JY5411_DI_SetReferenceTriggerType() : JY5411.h
  • JY5411_DI_SetReTriggerCount() : JY5411.h
  • JY5411_DI_SetSampleClock() : JY5411.h
  • JY5411_DI_SetSampleRate() : JY5411.h
  • JY5411_DI_SetSamplesToAcquire() : JY5411.h
  • JY5411_DI_SetStartTriggerType() : JY5411.h
  • JY5411_DI_SetTriggerDelay() : JY5411.h
  • JY5411_DI_Single : JY5411.h
  • JY5411_DI_Start() : JY5411.h
  • JY5411_DI_StartTrig : JY5411.h
  • JY5411_DI_StartTrigger : JY5411.h
  • JY5411_DI_Stop() : JY5411.h
  • JY5411_DI_TriggerMode : JY5411.h
  • JY5411_DI_WaitUntilDone() : JY5411.h
  • JY5411_DigitalTriggerEdge : JY5411.h
  • JY5411_DigitalTriggerSource : JY5411.h
  • JY5411_DIO_Digital : JY5411.h
  • JY5411_DIO_ExternalClock : JY5411.h
  • JY5411_DIO_ExternalSampleClockTerminal : JY5411.h
  • JY5411_DIO_Immediately : JY5411.h
  • JY5411_DIO_InternalClock : JY5411.h
  • JY5411_DIO_SampleClockSource : JY5411.h
  • JY5411_DIO_Soft : JY5411.h
  • JY5411_DIO_TriggerType : JY5411.h
  • JY5411_DisconnectSignalRouting() : JY5411.h
  • JY5411_DO_AddLines() : JY5411.h
  • JY5411_DO_CheckBufferStatus() : JY5411.h
  • JY5411_DO_CheckBufferStatusEx() : JY5411.h
  • JY5411_DO_ContinuousNoWrapping : JY5411.h
  • JY5411_DO_ContinuousWrapping : JY5411.h
  • JY5411_DO_Finite : JY5411.h
  • JY5411_DO_SampleClock : JY5411.h
  • JY5411_DO_SendSoftTrigger() : JY5411.h
  • JY5411_DO_SetDigitalStartTrigger() : JY5411.h
  • JY5411_DO_SetMode() : JY5411.h
  • JY5411_DO_SetSampleClock() : JY5411.h
  • JY5411_DO_SetSamplesToUpdate() : JY5411.h
  • JY5411_DO_SetStartTriggerType() : JY5411.h
  • JY5411_DO_SetTriggerDelay() : JY5411.h
  • JY5411_DO_SetUpdateRate() : JY5411.h
  • JY5411_DO_Single : JY5411.h
  • JY5411_DO_Start() : JY5411.h
  • JY5411_DO_StartTrig : JY5411.h
  • JY5411_DO_StartTrigger : JY5411.h
  • JY5411_DO_Stop() : JY5411.h
  • JY5411_DO_TriggerMode : JY5411.h
  • JY5411_DO_UpdateMode : JY5411.h
  • JY5411_DO_WaitUntilDone() : JY5411.h
  • JY5411_DO_WriteData() : JY5411.h
  • JY5411_DO_WriteSinglePoint() : JY5411.h
  • JY5411_DO_WriteSinglePoint_U32() : JY5411.h
  • JY5411_Falling : JY5411.h
  • JY5411_GetDeviceID() : JY5411.h
  • JY5411_GetDeviceSerialNumber() : JY5411.h
  • JY5411_Inter_DI_ReferenceTrig : JY5411.h
  • JY5411_Inter_DI_SampleClock : JY5411.h
  • JY5411_Inter_DI_StartTrig : JY5411.h
  • JY5411_Inter_DO_SampleClock : JY5411.h
  • JY5411_Inter_DO_StartTrig : JY5411.h
  • JY5411_Internal : JY5411.h
  • JY5411_Open() : JY5411.h
  • JY5411_OpenByName() : JY5411.h
  • JY5411_PFI0 : JY5411.h
  • JY5411_PFI1 : JY5411.h
  • JY5411_PFI2 : JY5411.h
  • JY5411_PFI3 : JY5411.h
  • JY5411_PFI4 : JY5411.h
  • JY5411_PFI5 : JY5411.h
  • JY5411_PFI6 : JY5411.h
  • JY5411_PFI7 : JY5411.h
  • JY5411_Power_Level : JY5411.h
  • JY5411_PXI_Clk100 : JY5411.h
  • JY5411_PXI_Trig0 : JY5411.h
  • JY5411_PXI_Trig1 : JY5411.h
  • JY5411_PXI_Trig2 : JY5411.h
  • JY5411_PXI_Trig3 : JY5411.h
  • JY5411_PXI_Trig4 : JY5411.h
  • JY5411_PXI_Trig5 : JY5411.h
  • JY5411_PXI_Trig6 : JY5411.h
  • JY5411_PXI_Trig7 : JY5411.h
  • JY5411_PXIe_DStarA : JY5411.h
  • JY5411_ReferenceClock : JY5411.h
  • JY5411_Rising : JY5411.h
  • JY5411_SetDeviceReferenceClock() : JY5411.h
  • JY5411_SetDeviceStatusLed() : JY5411.h
  • JY5411_SetPFIPower() : JY5411.h
  • JY5411_SignalRouting() : JY5411.h
  • JY5411_SignalSource : JY5411.h
  • JY5411_Terminal_PFI0 : JY5411.h
  • JY5411_Terminal_PFI1 : JY5411.h
  • JY5411_Terminal_PFI2 : JY5411.h
  • JY5411_Terminal_PFI3 : JY5411.h
  • JY5411_Terminal_PFI4 : JY5411.h
  • JY5411_Terminal_PFI5 : JY5411.h
  • JY5411_Terminal_PFI6 : JY5411.h
  • JY5411_Terminal_PFI7 : JY5411.h
  • JY5411_Terminal_PXITrig0 : JY5411.h
  • JY5411_Terminal_PXITrig1 : JY5411.h
  • JY5411_Terminal_PXITrig2 : JY5411.h
  • JY5411_Terminal_PXITrig3 : JY5411.h
  • JY5411_Terminal_PXITrig4 : JY5411.h
  • JY5411_Terminal_PXITrig5 : JY5411.h
  • JY5411_Terminal_PXITrig6 : JY5411.h
  • JY5411_Terminal_PXITrig7 : JY5411.h

- l -

  • Level_1p8 : JY5411.h
  • Level_2p5 : JY5411.h
  • Level_3p3 : JY5411.h
  • Level_5p0 : JY5411.h


  • __DLL_JY5411_DEVICE_H__ : JY5411.h


  • JY5411_ClockEdge : JY5411.h
  • JY5411_DestinationTerminal : JY5411.h
  • JY5411_DI_SampleMode : JY5411.h
  • JY5411_DI_TriggerMode : JY5411.h
  • JY5411_DigitalTriggerEdge : JY5411.h
  • JY5411_DigitalTriggerSource : JY5411.h
  • JY5411_DIO_ExternalSampleClockTerminal : JY5411.h
  • JY5411_DIO_SampleClockSource : JY5411.h
  • JY5411_DIO_TriggerType : JY5411.h
  • JY5411_DO_TriggerMode : JY5411.h
  • JY5411_DO_UpdateMode : JY5411.h
  • JY5411_Power_Level : JY5411.h
  • JY5411_ReferenceClock : JY5411.h
  • JY5411_SignalSource : JY5411.h


- j -

  • JY5411_Clock_Falling : JY5411.h
  • JY5411_Clock_PFI0 : JY5411.h
  • JY5411_Clock_PFI1 : JY5411.h
  • JY5411_Clock_PFI2 : JY5411.h
  • JY5411_Clock_PFI3 : JY5411.h
  • JY5411_Clock_PFI4 : JY5411.h
  • JY5411_Clock_PFI5 : JY5411.h
  • JY5411_Clock_PFI6 : JY5411.h
  • JY5411_Clock_PFI7 : JY5411.h
  • JY5411_Clock_PXIeDStarA : JY5411.h
  • JY5411_Clock_PXIeDStarB : JY5411.h
  • JY5411_Clock_PXIStar : JY5411.h
  • JY5411_Clock_PXITrig0 : JY5411.h
  • JY5411_Clock_PXITrig1 : JY5411.h
  • JY5411_Clock_PXITrig2 : JY5411.h
  • JY5411_Clock_PXITrig3 : JY5411.h
  • JY5411_Clock_PXITrig4 : JY5411.h
  • JY5411_Clock_PXITrig5 : JY5411.h
  • JY5411_Clock_PXITrig6 : JY5411.h
  • JY5411_Clock_PXITrig7 : JY5411.h
  • JY5411_Clock_Rising : JY5411.h
  • JY5411_Clock_SYNC100 : JY5411.h
  • JY5411_DI_Continuous : JY5411.h
  • JY5411_DI_Finite : JY5411.h
  • JY5411_DI_ReferenceTrig : JY5411.h
  • JY5411_DI_ReferenceTrigger : JY5411.h
  • JY5411_DI_SampleClock : JY5411.h
  • JY5411_DI_Single : JY5411.h
  • JY5411_DI_StartTrig : JY5411.h
  • JY5411_DI_StartTrigger : JY5411.h
  • JY5411_DIO_Digital : JY5411.h
  • JY5411_DIO_ExternalClock : JY5411.h
  • JY5411_DIO_Immediately : JY5411.h
  • JY5411_DIO_InternalClock : JY5411.h
  • JY5411_DIO_Soft : JY5411.h
  • JY5411_DO_ContinuousNoWrapping : JY5411.h
  • JY5411_DO_ContinuousWrapping : JY5411.h
  • JY5411_DO_Finite : JY5411.h
  • JY5411_DO_SampleClock : JY5411.h
  • JY5411_DO_Single : JY5411.h
  • JY5411_DO_StartTrig : JY5411.h
  • JY5411_DO_StartTrigger : JY5411.h
  • JY5411_Falling : JY5411.h
  • JY5411_Inter_DI_ReferenceTrig : JY5411.h
  • JY5411_Inter_DI_SampleClock : JY5411.h
  • JY5411_Inter_DI_StartTrig : JY5411.h
  • JY5411_Inter_DO_SampleClock : JY5411.h
  • JY5411_Inter_DO_StartTrig : JY5411.h
  • JY5411_Internal : JY5411.h
  • JY5411_PFI0 : JY5411.h
  • JY5411_PFI1 : JY5411.h
  • JY5411_PFI2 : JY5411.h
  • JY5411_PFI3 : JY5411.h
  • JY5411_PFI4 : JY5411.h
  • JY5411_PFI5 : JY5411.h
  • JY5411_PFI6 : JY5411.h
  • JY5411_PFI7 : JY5411.h
  • JY5411_PXI_Clk100 : JY5411.h
  • JY5411_PXI_Trig0 : JY5411.h
  • JY5411_PXI_Trig1 : JY5411.h
  • JY5411_PXI_Trig2 : JY5411.h
  • JY5411_PXI_Trig3 : JY5411.h
  • JY5411_PXI_Trig4 : JY5411.h
  • JY5411_PXI_Trig5 : JY5411.h
  • JY5411_PXI_Trig6 : JY5411.h
  • JY5411_PXI_Trig7 : JY5411.h
  • JY5411_PXIe_DStarA : JY5411.h
  • JY5411_Rising : JY5411.h
  • JY5411_Terminal_PFI0 : JY5411.h
  • JY5411_Terminal_PFI1 : JY5411.h
  • JY5411_Terminal_PFI2 : JY5411.h
  • JY5411_Terminal_PFI3 : JY5411.h
  • JY5411_Terminal_PFI4 : JY5411.h
  • JY5411_Terminal_PFI5 : JY5411.h
  • JY5411_Terminal_PFI6 : JY5411.h
  • JY5411_Terminal_PFI7 : JY5411.h
  • JY5411_Terminal_PXITrig0 : JY5411.h
  • JY5411_Terminal_PXITrig1 : JY5411.h
  • JY5411_Terminal_PXITrig2 : JY5411.h
  • JY5411_Terminal_PXITrig3 : JY5411.h
  • JY5411_Terminal_PXITrig4 : JY5411.h
  • JY5411_Terminal_PXITrig5 : JY5411.h
  • JY5411_Terminal_PXITrig6 : JY5411.h
  • JY5411_Terminal_PXITrig7 : JY5411.h

- l -

  • Level_1p8 : JY5411.h
  • Level_2p5 : JY5411.h
  • Level_3p3 : JY5411.h
  • Level_5p0 : JY5411.h


- j -

  • JY5411_Close() : JY5411.h
  • JY5411_DI_AddLines() : JY5411.h
  • JY5411_DI_CheckBufferStatus() : JY5411.h
  • JY5411_DI_CheckBufferStatusEx() : JY5411.h
  • JY5411_DI_ReadData() : JY5411.h
  • JY5411_DI_ReadSinglePoint() : JY5411.h
  • JY5411_DI_ReadSinglePoint_U32() : JY5411.h
  • JY5411_DI_SendSoftTrigger() : JY5411.h
  • JY5411_DI_SetDigitalReferenceTrigger() : JY5411.h
  • JY5411_DI_SetDigitalStartTrigger() : JY5411.h
  • JY5411_DI_SetMode() : JY5411.h
  • JY5411_DI_SetPreTriggerSamples() : JY5411.h
  • JY5411_DI_SetReferenceTriggerType() : JY5411.h
  • JY5411_DI_SetReTriggerCount() : JY5411.h
  • JY5411_DI_SetSampleClock() : JY5411.h
  • JY5411_DI_SetSampleRate() : JY5411.h
  • JY5411_DI_SetSamplesToAcquire() : JY5411.h
  • JY5411_DI_SetStartTriggerType() : JY5411.h
  • JY5411_DI_SetTriggerDelay() : JY5411.h
  • JY5411_DI_Start() : JY5411.h
  • JY5411_DI_Stop() : JY5411.h
  • JY5411_DI_WaitUntilDone() : JY5411.h
  • JY5411_DisconnectSignalRouting() : JY5411.h
  • JY5411_DO_AddLines() : JY5411.h
  • JY5411_DO_CheckBufferStatus() : JY5411.h
  • JY5411_DO_CheckBufferStatusEx() : JY5411.h
  • JY5411_DO_SendSoftTrigger() : JY5411.h
  • JY5411_DO_SetDigitalStartTrigger() : JY5411.h
  • JY5411_DO_SetMode() : JY5411.h
  • JY5411_DO_SetSampleClock() : JY5411.h
  • JY5411_DO_SetSamplesToUpdate() : JY5411.h
  • JY5411_DO_SetStartTriggerType() : JY5411.h
  • JY5411_DO_SetTriggerDelay() : JY5411.h
  • JY5411_DO_SetUpdateRate() : JY5411.h
  • JY5411_DO_Start() : JY5411.h
  • JY5411_DO_Stop() : JY5411.h
  • JY5411_DO_WaitUntilDone() : JY5411.h
  • JY5411_DO_WriteData() : JY5411.h
  • JY5411_DO_WriteSinglePoint() : JY5411.h
  • JY5411_DO_WriteSinglePoint_U32() : JY5411.h
  • JY5411_GetDeviceID() : JY5411.h
  • JY5411_GetDeviceSerialNumber() : JY5411.h
  • JY5411_Open() : JY5411.h
  • JY5411_OpenByName() : JY5411.h
  • JY5411_SetDeviceReferenceClock() : JY5411.h
  • JY5411_SetDeviceStatusLed() : JY5411.h
  • JY5411_SetPFIPower() : JY5411.h
  • JY5411_SignalRouting() : JY5411.h


  • JY5411_DeviceHandle : JY5411.h


5411 C++ Programming Manual: Main Page

5411 C++ Programming Manual Documentation